В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bogdan1001b
bogdan1001b
24.01.2020 00:01 •  Информатика

Синформатикой( два номера) программу, которая определяет попадает ли точка с вводимыми с клавиатуры координатами, в заданную область(окружность). см припрепленный файл.и вторая : напишите программу, которая определяет попадает ли точка в заданную область(см файл)

Ответ:
KiryaUly
KiryaUly
26.05.2020 04:11

Язык СИ:

1.

#include<stdio.h>

#include<math.h>

int main(){

   

   long double x,y;

   scanf("%Lf%Lf",&x,&y);

   

   printf("%s\n",sqrtl(x*x+y*y)<=2?"yes":"no");

   

   return 0;

   

}

2.

#include<stdio.h>

#include<math.h>

int main(){

   

   long double x,y;

   scanf("%Lf%Lf",&x,&y);

   

   printf("%s\n",-2<=x && x<=0 && -2<=y && y<=0?"yes":"no");

   

   return 0;

   

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?