В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
fumymovie
fumymovie
27.10.2021 00:40 •  Информатика

Друзья, кто шарит в информатике, прогу в паскале надо (30 на дороге не валяются)
составить программу. найти кол-во последовательных нечетных чисел (начиная с 1), сумма которых не превосходит 100.

Ответ:
UltraTwItTeR
UltraTwItTeR
27.08.2020 17:16

var k,s,i:Integer;

begin

while s<=100 do

begin

i:=i+1;

k:=k+1;

s:=s+(i*2-1);

end;

write(k-1)

end.

0,0(0 оценок)
Ответ:
lisasmirnova1
lisasmirnova1
27.08.2020 17:16

===== PascalABC.NET =====

begin

 var (s, i, k) := (1, 0, 100);

 while s <= k do

 begin

   i += 1;

   s += 2 * i + 1

 end;

 if s > k then

   i -= 1;

 SeqGen(i + 1, i -> 2 * i + 1).Println  

end.

Вообще задача решается без всякого программирования. Обычная сумма арифметической прогрессии с разностью 2.

(2 · 1 + 2(n - 1)) · n / 2 ≤ 100

n² ≤ 100 → n ≤ 10. Можно взять 10 нечетных чисел от 1 и их сумма будет ровно 100: 1+3+5+7+9+11+13+15+17+19 = 100


Друзья, кто шарит в информатике, прогу в паскале надо (30 на дороге не валяются) составить программу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?