В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
stalkeregor344
stalkeregor344
08.02.2020 14:59 •  Информатика

Точно и четко сформулировать условие , которая решается в данной программе program kr_2; var s1, s2, dg, dr, a : real; begin writeln('введите s1 и s2: '); readln(s1, s2); a : = sqrt(s1); dg : = a * sqrt(2); dr : = sqrt(4 * s2 / pi); if dg < = dr then writeln('да') else writeln('нет') end. точно известно, что dr - диаметр окружности, а что такое dg = sqrt(2*s1)? как же точно сформулировать ? формулировки типа сравнить 2 числа на катят.

Ответ:
vbfbk123
vbfbk123
21.07.2020 15:30
Проведем некоторые преобразования.
\displaystyle D_r= \sqrt{ \frac{4S_2}{\pi}} \to S_2= \frac{\pi D_r^2}{4}; \\ a= \sqrt{S_1}; \ &#10;D_g= a\sqrt{2};
Наиболее вероятное предположение, что S2 - формула площади круга с диаметром Dr, а S1 - формула площади квадрата со стороной a и диагональю Dg.
В программа сравнивается диагональ квадрата и диаметр окружности и если диагональ меньше диаметра, выводится "да", в противном случае выводится нет. Это позволяет сделать предположение о следующей постановке задачи:
"Можно ли поместить брусок квадратного сечения с площадью S1 в полый цилиндр с площадью основания S2 ?". Или, как вариант, пройдет ли брусок в отверстие..
0,0(0 оценок)
Ответ:
Løæålø
Løæålø
21.07.2020 15:30
Судя по коду, я нашёл значения переменных:
S_{1} - площадь квадрата, вписанного в круг.
S_{2} - площадь круга.
Dg - диагональ квадрата.
Dr - диаметр круга.
A - сторона квадрата.
Далее, разберём сам код:
С самого начала программа предлагает ввести площадь квадрата и площадь круга ("WriteLn('Введите S1 и S2: '); ") и записывает введённые значения в переменные S_{1} и S_{2} соответственно (ReadLn(S1, S2); ). Следующее действие программы - "A := SQRT(S1); " - не что иное, как вычисление длины стороны квадрата из площади(S_{square} = a^{2}; a = \sqrt{S;}). Далее - "Dg := A * SQRT(2); " - программа вычисляет диагональ квадрата, который ВПИСАН в круг, с формулы r = a \sqrt{2}.
Следующий шаг программы - "Dr := SQRT(4 * S2 / Pi); " - вычисляет диаметр круга согласно формуле d = \sqrt{ \frac{4 * S}{ \pi } }, которая выведена из формулы площади круга: S = \frac{ \pi }{4}d^{2}
Следующими действиями программа сравнивает два диаметра, один из которых был получен путём использования значений квадрата, а другой - значений круга. То есть, программа, сравнивая эти два значения диаметра, определяет, может ли квадрат быть вписан в круг, согласно данных, введённых пользователем, о площадях этих двух фигур.
Текст задачи может быть сформулирован так же: Напишите программу, которая бы определяла, может ли быть вписан квадрат в круг, исходя из значений их площадей, введённых пользователем.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?