В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sab005
sab005
09.01.2023 12:02 •  Информатика

Напишите программу, которая сортирует массив в порядке убывания. 7. Напишите программу, которая сортирует массив по возрас- танию последней цифры числа. C++

Ответ:
panoli2007
panoli2007
13.10.2020 13:32

Массив по убыванию:

#include<stdio.h>

#include<conio.h>

 

int numb[11];

int i,a,n;

 

int main()

{  

   //clrscr();

   for(i=0;i<=10;i++)

   {  

       numb[i]=i;

       printf (" %d",numb[i]);

   }

   n=1;

   while(n)

   {

           n=0;

           for(i=0;i<10;i++)

           {  

             if (numb[i]<numb[i+1])

             {  

                n=1;

                a=numb[i+1];numb[i+1]=numb[i];

                numb[i]=a;

             }

           }

   }

   for(i=0;i<=10;i++)  

       printf(" %d ",numb[i]);

   getch();

   return 0;

}

Сортировка массива по последней цифре:

#include <bits/stdc++.h>

 

   using namespace std;

   

bool f(const int rhs, const int lhs)

{

return (rhs % 10 < lhs % 10);

}

 

int main() {

   int n;

   cin >> n;

   int* arr = new int[n];

   for (int i = 0; i < n; i++) {

       cin >> arr[i];

   }

   sort(arr, arr + n, f);

   for (int i = 0; i < n; i++) {

       cout << arr[i] << " ";

   }

   delete [] arr;

   system("pause");

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?