В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
9999Ksenya999
9999Ksenya999
30.10.2021 15:23 •  Информатика

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).

Ответ:
NiKaEmpty
NiKaEmpty
20.07.2020 23:59
Program N94780249;
const
  s: longint = 0;
var
  x: longint;
  t: string;
  e: integer;
begin
  writeln('Вводите целые числа (0 - окончание ввода) : ');
  repeat
    repeat
      write('> ');
      readln(t);
      val(t, x, e);
      if e <> 0 then
        writeln('Ошибка! Повторите ввод. ')
    until e = 0;
    s += x
  until x = 0;
  if s = 0 then
    writeln('Числа не вводились. ')
  else
    writeln('Сумма введённых чисел = ', s, #10);
  write('Для завершения работы нажмите Enter...');
  readln
end.
0,0(0 оценок)
Ответ:
tskripko
tskripko
20.07.2020 23:59
Решение в прикрепленном файле :) 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?