В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lerka157
lerka157
03.12.2021 01:37 •  Информатика

Написать программу (процедуру), выводящую квадраты чисел от a до b (a,b вводятся с клавиатуры);

Ответ:
gameadventgary
gameadventgary
20.07.2020 14:20
И всё-таки, мне кажется, что надо вывести именно полные квадраты чисел в указанном диапазоне, иначе формулировка была бы типа: "Возведите в квадрат все числа в указанном диапазоне". Код на паскале:
var a, b, i, j : integer;
begin
readln(a, b);
for i := a to b do
begin
j := round(sqrt(i));
if j*j = i then writeln(i);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?