Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
usik6
27.11.2021 14:49 •
Информатика
Решить на pascal. дано: а(100)-произвольный найти: среднее арифметическое.
Ответ:
alina1923
20.07.2020 13:30
Program srof;
var a,b,c,d:real;
begin
writeln('введите любое количество цифр и завершите набор нажав 0');
readln(a);
b:=0;
c:=0;
while (a<>0) do
begin
b:=a+b;
c:=c+1;
readln(a);
end; d:=b/c;
writeln('ответ ',d);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
началось1939
30.03.2023 23:32
Розстав знаки арифметичних дій так, щоб отримати істинні рівності : 2 2 2 2 =10 , 5 5 5 5=10, (5 5) (5 5)=100...
sofiafrog2004
30.03.2023 23:32
Сформировать массив из n случайных чисел на промежутке [-50; 50].найти сумму четных чисел....
Фадиля
30.03.2023 23:32
Дан масcив из n целых чисел. написать программу,определяющую ,сколько в массиве чисел, равных максимальному элементу массива....
54Азиз
30.03.2023 23:32
Определите среднее арифметическое элементов массива....
yulyaanisimova2
22.01.2022 15:21
Составить программу печатающую квадрата всех натуральных чисел от 0 до заданного натурального n...
tiomashash
10.05.2023 10:51
Для хсохранения растрового изображения размером 1024x512 пикселей отвели 256 кбайт памяти. каково максимально возможное число цветов в палитре изображения? информатика...
Ябулочкасизюмом
10.05.2023 10:51
Сколько информации (в кбайтах) содержит текст состоящий из 900 символов, если известно, что каждый символ кодируется двумя байтами. ответ округлить до сотых с решением,...
Вадим321566787654
17.09.2020 09:48
cкласти блок схему алгоритму для знаходження середнього студента який отримав по 5 предметам оцінки x1 x2 x3 x4 x5...
РенатаG
23.04.2021 13:25
Пайтон. чи парне число введене з клавіатури? ...
Лес333
04.10.2020 11:31
Решите уравнение a+ не b+(b - (c+d))=0 сколько различных решений имеют уравнения a*b+c*d=1 (a+b) - (b*c*d)=0...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a,b,c,d:real;
begin
writeln('введите любое количество цифр и завершите набор нажав 0');
readln(a);
b:=0;
c:=0;
while (a<>0) do
begin
b:=a+b;
c:=c+1;
readln(a);
end; d:=b/c;
writeln('ответ ',d);
end.