В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nastya20081505
Nastya20081505
21.01.2020 11:48 •  Информатика

Написать программу в паскале! задан целочисленный массив из 10 случайных целых чисел. выполнить сортировку элементов массива,стоящих на четных номерах по убыванию методом пузырька.

Ответ:
сердянечок
сердянечок
02.10.2020 09:31
Const   
b=10;
var   
a: array[1..b] of integer;   
i, j, k: integer;
begin
Randomize;
Write ('Pervonachalnii massiv: '); 
for i := 1 to b do 
begin   
a[i] := random(100);   
Write (a[i]:4); 
end; 
Writeln; 
for i := 1 to b-1 do   
for j := 1 to b-i do   
if a[j] > a[j+1] then     
begin       
k := a[j];       
a[j] := a[j+1];       
a[j+1] := k;      
end;
 Write ('Otsortirovannii massiv: '); 
for i := 1 to b do 
begin   
Write (a[i]:4); 
end; 
Writeln;
Readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?