В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
EvgeniyNou
EvgeniyNou
23.01.2021 10:29 •  Информатика

Дано трехзначное число.найти сумму цифр числа.(написать программу на языке паскаль)

Ответ:
Qwertyuiopasdfghjkzz
Qwertyuiopasdfghjkzz
19.07.2020 12:17
Люблю работать в Паскале)
0,0(0 оценок)
Ответ:
mashamasha221
mashamasha221
19.07.2020 12:17
Program chisla;
uses crt;
var a,b,c,d : integer;
begin
Writeln('Введите трехзначное число: ');
Readln(a);
if (a<100) or (a>999) then writeln('Введено не трехзначное число')
else
begin
b:=a div 100;
c:=(a-(b*100)) div 10;
d:=a-(b*100)-(c*10);
Writeln('Сумма цифр этого числа равна ',b+c+d);
end
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?