В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
optymus
optymus
24.09.2020 04:48 •  Информатика

Решение с использованием строк 1. составьте программу, которая: а) из слова «компилятор» составляет слова: «мотор», «комок», «пилот»; б) из слов «мандарин», «мода», «мак» получает слово «командор»; в) заменяет в тексте, заданном с клавиатуры, пробелы между словами подчеркиванием.

Ответ:
анг26
анг26
15.07.2020 17:51
Var
str, s, s1, s2, s3: string;
i:integer;
begin
str:='ÊÎÌÏÈËßÒÎÐ';
s:=str[3]+str[2]+copy(str, 8, 3);
writeln(s);
s:=copy(str, 1, 3)+str[2]+str[1];
writeln(s);
s:=copy(str, 4, 3)+str[2]+str[length(str)-2];
writeln(s);
s1:='ÌÀÍÄÀÐÈÍ'; s2:='ÌÎÄÀ'; s3:='ÌÀÊ';
s:=copy(s3, 3, 1)+copy(s2, 2, 1)+copy(s1, 1, 4)+copy(s2, 2, 1)+copy(s1, length(s1)-2, 1);
writeln(s);
writeln('Vvedite stroku:');
readln(str);
for i:=1 to length(str) do
if str[i]=' ' then str[i]:='_';
writeln(str);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?