Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
barbara27
31.01.2023 08:04 •
Информатика
С#, консоль дан целочисленный массив размера n. вставить после каждой его серии элемент с нулевым значением. серия - это группа подряд идущих одинаковых элементов, длина серии — количество этих элементов (длина серии может быть равна 1).
Ответ:
mira0209
12.07.2020 12:58
Using System;
static void Main()
{
int[] sourceArray = new int[] {3, 1, -4, -4, 65}; //Исходный массив
int[] newArray = new int[sourceArray.Length * 2]; //Новый массив с максимальной нужной длиной
int newArrayIndex = 0; //Индекс для нового массива
for (int i = 0; i < sourceArray.Length; i++)
{
newArray[newArrayIndex++] = sourceArray[i];
if (i == sourceArray.Length - 1 || sourceArray[i] != sourceArray[i + 1])
newArray[newArrayIndex++] = 0;
}
for (int i = 0; i < newArrayIndex; i++) //Выводим новый массив на экран
Console.Write(newArray[i] + " ");
Console.ReadKey();
}
0,0
(0 оценок)
Популярные вопросы: Информатика
ruslan427
30.03.2021 04:27
Выберете верный адрес ячейки в электронной таблице: 1)64Е 2)АЛЗ 3)К33 4)S3B Сколько ячеек содержит диапозон А2:B4 Адрес ячейки в электронной таблице определяется-?...
MOJH
28.06.2021 01:24
Запиши программу на языке Паскаль, запусти программу и введи значение x = 17 Число, выведенное на экран:...
donchikbukhmas
04.03.2020 01:00
Виправити помилки у записі виконання команди у середовищі Lazarus: А) Form1.Top:Form1.Top+40; Б) Form1. Сaption Розклад; В) Form.Left:400;...
reor1878p02hjw
29.03.2021 06:35
Даны действительные числа x, а, с. Написать программу на языке Паскаль для вычисления выражения...
Druwba
17.03.2021 04:33
информационные процессы - поиск, сбор, хранение, отправка, использование, обработка. Мне нужны примеры 5 класс...
tanygina067
11.05.2021 21:21
Сообщение записано с алфавита мощностью в 8символы. Вес сообщения -120 битов. Найдите количество символов в данном сообщении.Выбери из правильного варианта ответа.8 символы120 символы16 символы15 символы40 символы...
Donyakotova
09.03.2021 15:53
Компьютерлік жад дегеніміз не?...
gigeriti28391vlad
17.02.2020 08:34
Решите уравнения: а)х-13/18х=1/3 б)20х-13х-12х=0,6 /-дробь...
America555
17.02.2020 08:34
Внутреннее и внешнее положение россии в начале и конце 17 века....
nmnurislom
17.02.2020 08:34
Как сделать сестре морфологический разбор прилагательного: холодное? !...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
static void Main()
{
int[] sourceArray = new int[] {3, 1, -4, -4, 65}; //Исходный массив
int[] newArray = new int[sourceArray.Length * 2]; //Новый массив с максимальной нужной длиной
int newArrayIndex = 0; //Индекс для нового массива
for (int i = 0; i < sourceArray.Length; i++)
{
newArray[newArrayIndex++] = sourceArray[i];
if (i == sourceArray.Length - 1 || sourceArray[i] != sourceArray[i + 1])
newArray[newArrayIndex++] = 0;
}
for (int i = 0; i < newArrayIndex; i++) //Выводим новый массив на экран
Console.Write(newArray[i] + " ");
Console.ReadKey();
}