В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
doktornastia03
doktornastia03
31.07.2020 00:44 •  Информатика

Написать программу на free pascal которая переводит число из десятичной системы в двоичную

Ответ:
prostotak1970
prostotak1970
12.07.2020 11:28
Function ToBinaryString(x: integer): string;
var r, s: string;
begin
  if x < 0 then begin
    s := '-';
    x := -x;
  end;
  while x <> 0 do begin
    r := Chr((x and 1) or 48) + r;
    x := x shr 1;
  end;

  ToBinaryString := s + r;
end;

var x: integer;
begin
  readln(x);
  writeln(ToBinaryString(x));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?