В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1234567891243
1234567891243
15.07.2022 12:27 •  Информатика

Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример : введите два числа: 10-15,10*(-15)=-150

Ответ:
kama1ezeGggggg
kama1ezeGggggg
12.07.2020 09:13
Var  a, b, prod, i: integer;
begin
  writeln('Введите два числа: ');
  readln(a, b);
  prod := 0;
  if (b < 0) then
    for i := b to -1 do
      dec(prod, a)
  else
    for i := 1 to b do
      inc(prod, a);
  writeln(prod)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?