Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
кракодиллох2
07.03.2020 10:47 •
Информатика
Нужно задать массив целых чисел. вывести на экран только те значения элементов массива, которые встречаются в нем более одного раза, при этом каждое найденное значение должно быть распечатано столько раз, сколько оно встречается.
Ответ:
карамелька115
09.07.2020 15:52
Решение этой задачи на языке С++# include <iostream># include <math.h># include <cmath>using namespace std;int main(){ int b,a[1001] , i = 0 , j = 1 , k = 0; while(cin>>b) { a[j] = b; i++; j++; } for(j = 2; j <= i; j++) { if(((a[j - 1] > 0) && (a[j] > 0))||((a[j - 1] < 0)&&(a[j] < 0))){ cout<<a[j-1]<<" "<<a[j]; return 0; } } return 0;}
0,0
(0 оценок)
Ответ:
sviktoria77777
09.07.2020 15:52
Program masof;
var ar: array of integer;
i, j, temp, N: integer;
begin
readln(N);
setlength(ar, N+1);
for i:=1 to N do begin readln(ar[i]); end;
for i:=1 to N do begin
temp:=0;
for j:=1 to N do begin if ar[j]=ar[i] then inc(temp); end;
if temp>1 then write(ar[i], ' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ilovemath777
21.03.2020 11:55
Как называется область памяти, используемая для создания копий какого-то фрагмента информации (рисунка или текста), а также для переноса таких фрагментов между разными...
ogh30662
05.12.2021 00:21
Для чого використовує компьютер вчитель,лікар,бібліотекар...
beatsdol
11.02.2023 02:11
Скакой целью производится рассылка ?...
KsushaTrefilova
11.02.2020 16:32
От станции до озера s км. туристы, напрявляясь от станции к озеру, полтора часа шли пешком со скоростью а км, а затем сели на попутную машину, которая ехала со скрость....
жанель98
24.03.2021 02:53
Написать программу которая в двух значном числе будет находить первую цифру затем умножать её на 5 и результатом выводить на экран , ! ...
8aA7
23.09.2021 12:48
Зарплата менеджера составляет 200$ + процент от продаж. продажи до 500$ - 3%, от 500 до 1000 – 5%, свыше 1000 – 8%. пользователь вводит с клавиатуры уровень продаж...
llll41
23.09.2021 12:48
Расстояние между домами, в которых живут петя и коля, 1200м. однажды они вышли каждый из своего дома и направились навстречу друг другу. когда петя а метров они встретились....
Ruslan3252
27.01.2022 07:54
Решить по информатике : 1) сколько информации получает человек , при получении сообщения : из 128 конкурсантов , победил игрок под номером 5 ? 2) найдите количество...
Myzhik123456
05.12.2022 22:33
Головной мозг разобраться нужно ...
grbennikovigor
21.01.2022 12:18
Маленький шарик массой 10 г движется вдоль прямой согласно уравнению х = 2 − t + t^2. определите импульс шарика через 2 с после начала отсчёта времени....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var ar: array of integer;
i, j, temp, N: integer;
begin
readln(N);
setlength(ar, N+1);
for i:=1 to N do begin readln(ar[i]); end;
for i:=1 to N do begin
temp:=0;
for j:=1 to N do begin if ar[j]=ar[i] then inc(temp); end;
if temp>1 then write(ar[i], ' ');
end;
end.