В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
умник1235678
умник1235678
28.09.2020 06:08 •  Информатика

Составьте программу, определяющую принадлежность точки а(х, у) окружности с центром 0(0; 0) и радиусом r. в паскалеabc.

Ответ:
Kirilloo673
Kirilloo673
01.10.2020 22:53
Var x,y,r:real;
begin
writeln('Введите радиус окружности');
readln(r);
writeln('Введите координаты точки А');
readln(x,y);
if sqr(x)+sqr(y)=sqr(r) then writeln('Принадлежит')
else writeln('Не принадлежит');
end.
0,0(0 оценок)
Ответ:
marylps45
marylps45
01.10.2020 22:53
Var x,y,r:real;
begin
readln(r);
readln(x,y);
    if sqr(x)+sqr(y)<=sqr(r) then
        writeln('принадлежит')else writeln('не принадлежит');
end.
в предыдущем решении точка лежит только на границе окружности
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?