Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Anolu
16.07.2022 04:20 •
Информатика
Записать программу формирования и выведения масива а розмером n, который содержит n первых элементов последовательности чисел фибоначчи
Ответ:
Аня24204
08.07.2020 02:01
const
n = 10;
var
a: array [1..n] of integer;
begin
a[1] := 1;
a[2] := 2;
write('1 2 ');
for i: integer := 3 to n do
begin
a[i] := a[i - 2] + a[i - 1];
write(a[i], ' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Сонечка2155
14.03.2023 02:33
Составить программу,позволяющую по последней цифре данного числа определить последнюю цифру квадрата этого числа...
Linkin251
14.03.2023 02:33
1. 1100110 двоичная перевести в восьмеричную 2. 7f в шестнадцатеричной перевести в двоичную 3. 98 десятеричной перевести в двоичную 4. 1111,011 двоичная перевести...
bogdan345710
14.03.2023 02:33
Произведение средних арифметических массивов a и в паскаль, !...
mashkabaku
21.04.2021 22:50
Укажите ложные высказыванияРусские буквы в кодовых таблицах КОИ-8 и Windows расположены в лексикографическом порядкеРусские буквы в кодовых таблицах КОИ-8 и Windows...
kutluyulovarrr
15.03.2021 04:21
, ответ дать в Кбайт и в Мбайт с подробным решением и с формулами...
ViktorVivat
09.05.2022 20:48
Дроби Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт Алтан учится...
Vladimirmir28
16.05.2021 06:50
Для групповых операций с файлами используются маски имён файлов. маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов,...
akrikay13
16.05.2021 06:50
Сделать программу в pascal.пользователь вводит радиус окружности и стороны прямоугольника , программа в графическом режиме выводит нам получившийся прямоугольник...
DARO100
20.02.2022 13:31
Что заставила лидию михайловну играть на деньги с учеником?...
хеллокиттичка
20.02.2022 13:31
Один каменщик уложил за день 2.350 кирпечей, а другой - на147 кирпичей больше. сколько кирпичей эти каменщики могут уложить вдвоем за 5 дней, укладывая в день такое...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 10;
var
a: array [1..n] of integer;
begin
a[1] := 1;
a[2] := 2;
write('1 2 ');
for i: integer := 3 to n do
begin
a[i] := a[i - 2] + a[i - 1];
write(a[i], ' ');
end;
end.