В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Molyaa97
Molyaa97
28.05.2023 07:14 •  Информатика

Написать программу замены положительных элементов вещественного массива y[1..n] на 0. (паскаль-массивы)

Ответ:
vasiaska234
vasiaska234
07.07.2020 19:05
Решение в файле

uses crt;
var a: array of integer;    n, i: integer;    begin
WriteLn('Введите N');ReadLn(n);
a := new integer[n];
randomize; //заполняем массив случайными значениямиfor i:=0 to n-1 dobegina[i]:=random(100)-50;Write(a[i]:5);end;Writeln;
for i:=0 to n-1 do //заменяем положительные элементы нулемbeginif a[i]>0 then a[i]:=0;Write (a[i]:5);end;writeln;readln;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?