В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
anna18341
anna18341
22.08.2022 06:44 •  Информатика

Напишите программу, которая проверяет, не ли суммирование двух заданных целых чисел(определенного типа) к переполнению.

Ответ:
бакыт6
бакыт6
07.07.2020 14:22
Const
  low=-32768;
  high=32767;
Var i, j :integer;
begin
  readln(i,j);
  if sign(i)*sign(j)<0 then writeln('Сложение допустимо, результат ',i+j)
  else
    if i<0 then
      if j<low-i then writeln('Сложение недопустимо: возникнет переполнение')
      else writeln('Сложение допустимо, результат ',i+j)
    else
      if j>high-i then writeln('Сложение недопустимо: возникнет переполнение')
      else writeln('Сложение допустимо, результат ',i+j)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?