В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно).

Ответ:
настя7594
настя7594
07.07.2020 13:14
Var
  i,k,m,j:integer;
  a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i]:3);
  end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
  begin
  b[j]:=a[i];
  j:=j-1;
  end;
for i:=k to m do  a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i]:3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?