Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
vladgoncharov2p01aun
22.09.2021 14:41 •
Информатика
Написать программу, которая вставляет число k в заданную возрастающую последовательность таким образом, что в результате полученная последовательность также остается полностью возрастающей. (язык программирования - паскаль) - писать адекватно
Ответ:
AlexeyCherkasa
06.07.2020 22:35
Var a:array[1..11] of integer;
i,k,t:integer;
begin
for i:=1 to 10 do
read(a[i]);
read(k);
for t:=1 to 11 do
if a[t]>k then break;
for i:=11 downto t+1 do
a[i]:=a[i-1];
a[t]:=k;
for i:=1 to 11 do
write(a[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
асел9
26.09.2021 00:53
Задание 2.1. Приведите пример 3D-моделей и применение трехмерной графики ( ) куклаКомпьютерное моделирование физических объектовфотографияСоздание видеороликовбумажный самолетикгеографическая...
ALEXFORBIDDEN
13.04.2021 21:58
Статья,набранная на компьютере,содержит 16 страниц,на каждой странице 35 строки,на каждой строке 64 символов. определите информационный объём статьи в одной из кодировке windows-1251,...
Katrun15
13.04.2021 21:58
Қөрнектерді есептеу үшін қолданылатын іс əрекеттің атауы қалай аталады...
andreevik2003
14.04.2020 23:35
Оперативная память необходима для ... A Хранения неизменной информации B долго хранения информации C кратко хранения информации D удаления информации E долго хранения неизменной...
Aytgbssh
29.06.2022 22:57
по информатике 8й класс 1)Переведите максимальное трехзначное восьмеричное число в десятичную систему счисления. 2)Выполните сложение двух чисел 547 и 341. ответ запишите в десятичной...
sab005
15.06.2022 03:23
Основные составляющие программного обеспечения ... A языки программирования и компьютерные вирусы B инструментальные средства и системное ПО C компилятор и интерпретатор D драйвер...
kekngh
12.02.2020 13:44
Программа на паскаль найти количество элементов массива целых чисел c(14), больших куба второго элемента массива этого массива. если таких элементов нет выдать сообщение- поиск...
PRPPAPIG2004
12.02.2020 13:44
Вмассиве, заполненном произвольными целыми числами, найдите два числа, произведение которых максимально. вложенные циклы не используйте. ! на паскале...
8Мария11
12.02.2020 13:44
Напиши все возможные решения ребуса: *** – ** + * = 2...
Bonta
12.02.2020 13:44
Отренировках план тренировок пробежать 10 км . каждый следующий день увеличивать расстояние на 10% от результата предыдущего дня . как только дневной пробег достигнет или превысит...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
i,k,t:integer;
begin
for i:=1 to 10 do
read(a[i]);
read(k);
for t:=1 to 11 do
if a[t]>k then break;
for i:=11 downto t+1 do
a[i]:=a[i-1];
a[t]:=k;
for i:=1 to 11 do
write(a[i],' ');
end.