В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Koshka1563
Koshka1563
10.08.2020 04:24 •  Информатика

дана информация о температуре воздуха за январь. написать программу, которая: а)определит сколько раз температура опускалась ниже 0 градусов б)определит среднюю температуру за январь

Ответ:
1234567891155
1234567891155
01.10.2020 19:54
Var
   st:real;
   i,n:integer;
   t:array[1..31]of integer;
begin
writeln('Температура в январе:');
for i:=1 to 31 do
  begin  t[i]:=random(-10,5);
  write(t[i],' ');
  st:=st+t[i];
  if t[i]<0 then n:=n+1
  end;
st:=st/31;
writeln;
writeln('Число дней с отр.температурой: ',n);
writeln('Средняя температура: ',st:1:1)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?