Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Himop
21.07.2021 12:44 •
Информатика
Напишите код на паскале. сама : посчитать частоту встречаемости каждой буквы алфавита в введенном тексте.
Ответ:
elizaveta1705fomina
06.07.2020 01:24
Var a:array[1..33] of integer;
s:string;
i:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['А'..'Я'] then a[(ord(s[i])-ord('А')+1)]+=1
else a[(ord(s[i])-ord('а')+1)]+=1;
for i:=1 to 33 do
write(a[i],' ');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
rakhmanets
27.09.2020 23:11
Решите предыдущую учитывая возможности одинаково возраста саши и маши. в таком случае может быть получен ответ саша и маша ровесники...
AgamanDi
27.09.2020 23:11
3. дан следующий алгоритм: пока впереди не край повторять нц поворот кц при каком исходном положении графического исполнителя данный алгоритм зациклится?...
MorohaHaimura
27.09.2020 23:11
:написать программу нахождения наибольшего среди четырёх заданных чиселв паскале: )...
harwq
27.09.2020 23:11
Определить результат при х=6; х=-5: if x 10 then x: =10 else if x 15 then x: = 16 else x: = 20...
Lizaveta20021
20.08.2022 00:32
Напишите комментарии к программе на с++, что к чему скажем так. было такое: заполните случайным образом массив (100 элементов) поочередно бук-вами латинского алфавита...
davidgjggjj
28.08.2022 15:37
Определить объем памяти для хранения цифрового аудиофайла, время звучания которого 5 мин при частоте дискретизации 44,1 кгц и глубине кодирования 16 битов....
НАСТЯ7539
12.12.2022 08:21
Мальчик рисует для своего приятеля схему дороги от школы до его дома. 1. Объектом-оригиналом в данной ситуации является дорога 2. Моделью является...
вор9
08.02.2020 10:26
У Инфознайки и его приятеля Смельчака спросили, сколько слов в минуту вы можете набрать на компьютере? Смельчак сказал: «Я могу набрать половину слов от того, что набирает...
jon10079595
13.02.2020 00:47
9. Тип данных, каждый ключ которого соответствует определенному значению.окортежОстрокиОспискиОсловарьлогический тип...
dwawd
01.09.2022 16:25
Сколько различных пятибуквенных слов (не обязательно осмысленных) можно составить, переставляя буквы К, О, Р, Р, М? При этом буква К может стоять либо в начале, либо...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
s:string;
i:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['А'..'Я'] then a[(ord(s[i])-ord('А')+1)]+=1
else a[(ord(s[i])-ord('а')+1)]+=1;
for i:=1 to 33 do
write(a[i],' ');
end.