В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dkrechetov85
dkrechetov85
23.02.2022 02:41 •  Информатика

Напишите программу в паскаль для решения : ввести натуральное число и определить, верно ли, что сумма его цифр равна 10

Ответ:
perrezz
perrezz
01.10.2020 19:38
begin
  var s: string;
  var i, k: integer;
  readln(s);
  try
    foreach c: char in s do
      k += Byte.Parse(c);
    writeln(k);
  except
    on System.FormatException do
        writeln('Введи число -_-');
    else writeln('Ошибка');
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?