В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составьте программу позволяющую проверить умение выполнить сложение двух целых чисел, каждая из которых не больше ста. p.s. чуваки, от этого зависит моя четвертная оценка

Ответ:
SBusic
SBusic
03.07.2020 17:19
var
  i, k, f, a, b: byte;

begin
   for i := 1 to 10 do
  begin
    a := random(0, 99);
    b := random(0, 99);
    write(String.Format('{0} + {1} = ', a, b));
    readln(k);
    f += (a + b = k ? 1 : 0);
  end;
  writeln(String.Format('{0} правильных из 10', f));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?