В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
10121945
10121945
05.04.2021 11:26 •  Информатика

Сорочно программу которая в последовательности целых чисел определяет кол-во кратных 5 или 7 . программа получает на вход целые числ кол-во введеных чисел неизвестно последовальность чисел заканчивается число 0 ( 0 признак окончания ввода не входит в последовательность) ко-во чисел не превышает 1000 введеные числа по модулу не превышает 30 000 программа должна вывести оно число кол-во чисел кратных 5 или 7 пример работы - 22 25 -14 0 выходные данные 2

Ответ:
Elizzzavettta
Elizzzavettta
03.07.2020 17:02
Using System;

namespace ConsoleApp {
    internal class Program {
        private static void Main() {
            var number = 0;
            int n;
            do {
                Console.WriteLine("Введите число");
                n = Convert.ToInt32(Console.ReadLine());
                if (n != 0 && (n % 5 == 0 || n % 7 == 0)) {
                    number++;
                }
            } while (n != 0);

            Console.WriteLine("Кол-во = " + number);

            Console.ReadKey();
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?