В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sofia2224
Sofia2224
08.08.2020 02:16 •  Информатика

Нужно написать программу на паскале. вычислить среднеарифметическое четных элементов массива c(10), не меньших 10

Ответ:
Алина678901
Алина678901
02.07.2020 20:28
Var
c:array[1..10] of integer;
SrAr:real;
k, i, s:integer;
begin
s:=0;{Обнуляем счетчик элементов(к) и сумму(s)}
k:=0;
randomize;
for i:=1 to 10 do {заполняем массив}
 c[i]:=random(50);
for i:=1 to 10 do
 if (c[i] mod 2=0) and (c[i]>10) then {если элемент массива четный и больше 10 увеличиваем счетчик к, увеличиваем сумму s} 
   begin
   k:=k+1; 
   s:=s+с[i];
   end;
SrAr:=s/k;
for i:=1 to 10 do {выводим массив}
write(c[i], ' ');
writeln;
writeln('Sr.Arifmeticheskoe=', SrAr:5:2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?