Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
amalia454565
29.11.2022 05:32 •
Информатика
Составьте программу для вычисления площади четырёхугольника с координатами вершин (x1, , , , y4).площадь четырёхугольника вычислите как сумму площадей двух треугольников.
Ответ:
then3rvnyy
29.06.2020 07:20
TYPE
TPoint = Record x, y: Real; End;
VAR
a, b, c, d: TPoint;
Function Pl(a, b, c: TPoint): Real;
Var v1, v2: TPoint;
Begin
v1.x := a.x - b.x; v1.y := a.y - b.y;
v2.x := a.x - c.x; v2.y := a.y - c.y;
Pl := Abs(v1.x * v2.y - v1.y * v2.x) / 2;
End;
BEGIN
Read(a.x, a.y, b.x, b.y);
Read(c.x, c.y, d.x, d.y);
Write(Pl(a, b, c)+Pl(a, c, d));
END.
0,0
(0 оценок)
Популярные вопросы: Информатика
твоёсолнце7
20.03.2020 07:03
Информатика, 9 класс. составить программу для решения : напечатать таблицу перевода 1, долларов сша в рубли по текущему курсу (значение вводится с клавиатуры)....
незнайка1185
06.01.2020 06:59
Ничего во не понимаю в этой теме...
shtoshpulodov
11.05.2022 17:15
Составить программу, которая запрашивает пароль (трехзначное число + 2 символа) до тех пор, пока он не будет правильно введен. Верный пароль должен быть задан в...
fatimatagiyeva
12.04.2021 16:55
Применение вс алгоритмов в записи цифр и букв Укажите правильный вариант ответа: удлинняет алгоритм упрощает алгоритм запутывает алгоритм...
холера663
12.12.2022 04:59
Дан массив x100. найти сумму эелементво массива от x1 до xmin...
aodushkina824oya9o5
12.12.2022 04:59
Определите значение переменной s после выполнения следующих операторов(ответ запишите с решением): s: =0; for i: =1 to 3 do begin s: =s + 2; s: =s*i; end;...
glafira23
12.12.2022 04:59
Вычислите сумму чисел х и у,если х=а516 , у=3568. результат предьставтьте в двоичной системе счисления....
10802
12.12.2022 04:59
При работе с электронной таблицей в ячейке н5 записана формула =$в$5*5 . какая формула будет получена из нее при копировании в ячейку н7?...
aselimsovetova
16.09.2020 14:24
Які основні показники всесвітньої організації охорони здоров я свідчить про ефективність роботи системи охорони здоров я в країні? 1. Кількість закладів охорони...
AcidSmile
12.09.2020 08:22
Один киломоль газа изобарически нагревается от 17 до 75 ºС, при этом газ поглощает 1,2⋅10^6 Дж теплоты. Найти приращение внутренней энергии и работу газа....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
TPoint = Record x, y: Real; End;
VAR
a, b, c, d: TPoint;
Function Pl(a, b, c: TPoint): Real;
Var v1, v2: TPoint;
Begin
v1.x := a.x - b.x; v1.y := a.y - b.y;
v2.x := a.x - c.x; v2.y := a.y - c.y;
Pl := Abs(v1.x * v2.y - v1.y * v2.x) / 2;
End;
BEGIN
Read(a.x, a.y, b.x, b.y);
Read(c.x, c.y, d.x, d.y);
Write(Pl(a, b, c)+Pl(a, c, d));
END.