В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tiamaressp035gw
tiamaressp035gw
18.12.2022 15:12 •  Информатика

Составить программу нахождения наибольшего числа из введенных с клавиатуры. в паскале с цикла.

Ответ:
zska25
zska25
28.06.2020 15:50
Var max,n,c,i:integer;
begin
readln(n); //сколько чисел будет всего введено
readln(c);
max:=c;
for i:=1 to n-1 do begin
   readln(c);
   if max<c then max:=c;
   end;
writeln(max);
end.
//это один из самых производительных алгоритмов, без лишних записей в массив и траты памяти
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?