В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vaniev2006
vaniev2006
17.01.2022 00:45 •  Информатика

Сделать в паскале. составьте программу, которая удаляет из слова x те буквы, которые встречаются в слове z. слова x и z вводятся с клавиатуры.

Ответ:
пикча6
пикча6
28.06.2020 01:16
var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);

for i:=1 to Length(z) do
  ar[z[i]]:=true;
  for i:=Length(x) downto 1 do
    if (ar[x[i]] = true) then delete(x,i-1,1);   
writeln(x);
end.

Не забудь отметить лучший ответ ;-)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?