В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1saridua1
1saridua1
14.02.2021 15:27 •  Информатика

Программу на языке pascal: для ремонта кабинета шириной а метров, длиной b метров, высотой h метров необходимо купить в магазине обоев. площадь окон и дверей не учитывать. известна стоимость одного рулона (86 рублей) обоев длиной 12 м и шириной 0,6 м. составьте программу определяющую, какая сумма необходима для покупки обоев.

Ответ:
prve17
prve17
01.10.2020 13:47
Program olraisinsss;
const n=86; z=12; c=0.6;
var a,b,h,p1,sum:integer;   
     p2:real;
begin
write('a=');read(a);
write('b=');read(b);
write('h=');read(h);
p1:=4*(b+h)+4*(a+h);

while p2<p1 do begin
p2:=p2+2*(z+c);
sum:=sum+1;
end;
writeln('Price=',sum*n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?