В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
вау1905
вау1905
22.01.2020 09:39 •  Информатика

Напишите программу, разделяющую мелодии разных видов лягушек. К розовым лягушкам (Pink Frogs) относятся числа, кратные пяти или большие 1000.

К ядовитым (Poisonous frogs) относятся нечетные, меньшие 99.

К крапчатым (Speckled frogs) – четные, в разряде десятков у которых стоят 8 или 9.

Формат ввода

Вводится количество чисел, затем сами числа.

Формат вывода

Выведите информацию, относящуюся к разным видам лягушек, в виде:

Pink Frogs: <разность наибольшего и наименьшего из подходящих чисел>.

Poisonous frogs: <сумма подходящих чисел>.

Speckled frogs: <количество подходящих чисел>.

Если в первой группе оказывается одно число, то оно считается и наибольшим, и наименьшим.

Пример 1

Ввод Вывод

7

182

363

693

26

345

1037

530

Pink Frogs: 692.

Poisonous frogs: 0.

Speckled frogs: 1.

Пример 2

Ввод Вывод

9

975

6405

164

498

77

58

490

41

298

Pink Frogs: 5915.

Poisonous frogs: 118.

Speckled frogs: 3.

Ответ:
Kisson
Kisson
29.12.2021 01:00

ответ: python

Pink = []

Poisonous = 0

Speckled = []

for i in range(int(input())):

   n = int(input())

   if n > 1000 or n % 5 == 0:

       Pink.append(n)

   if n < 99 and n % 2 == 1:

       Poisonous += n

   if n % 2 == 0 and (n // 10) % 10 == 8 or (n // 10) % 10 == 9:

       Speckled.append(n)

Pink.sort()

print('Pink Frogs:', str(Pink[-1] - Pink[0]) + '.')

print('Poisonous frogs:', str(Poisonous) + '.')

print('Speckled frogs:', str(len(Speckled)) + '.')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?