В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Shbtura01
Shbtura01
06.06.2021 14:28 •  Информатика

На PYTHON Напишите программу, которая выводит на экран спираль из 60
пятиугольников с разными цветами контура.

Ответ:
svetakurilova
svetakurilova
08.12.2021 15:30

{Выводит узор из 100 произвольно размещенных окружностей произвольного

радиуса и цвета}

uses Graph;

var

grDriver:integer;

grMode: integer;

grPath:string;

ErrCode:integer;

x,y,r: integer; ( координаты центра и радиус окружности }

i: integer;

begin

grDriver:=VGA;

grMode:=VGAHi;

grPath:=' ';

InitGraph (grDriver,grMode,grPath);

ErrCode:=GraphResult;

if ErrCode <> grOk then

begin

writeln ('Ошибка инициализации графического режима.1);

writeln ('Для завершения работы нажмите <Enter>');

readln;

Halt(l);

end;

Randomize;

for i:=l to 100 do

begin

x:=Random(640);

y:=Random(480);

r:=Random(240);

Setcolor(Random(16));

Circle(x,y,r);

end;

readin;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?