В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kokoulina68
kokoulina68
02.06.2021 10:22 •  Информатика

Составьте программу, которая генерирует и выводит на экран длины сторон катетов прямоугольного треугольника, не превыщающих 10 см. Программа должна подсчитать длину гипотенузы этого треугольника, его площадь и периметр и вывести их на экран. Затем эти вычисленные значения следует округлить и вывести результат на экран в отдельной строке (Phyton/Питон)

Ответ:
verysadsavant1
verysadsavant1
04.01.2022 06:40

import math

import random

a = random.randint(2,10)

b = random.randint(2,10)

while a == b:

   a = random.randint(2,10)

   b = random.randint(2,10)

print("a =", a, "см", "b =", b, "см.")

c = math.sqrt(a**2+b**2)

print("c =",'%.1f' % c, "см.")

p = a+b+c

print("P =",'%.1f' % p, "см.")

s = (a*b)/2

print("S =",'%.1f' % s, "см^2.")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?