В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
дибилон1
дибилон1
08.08.2021 18:25 •  Информатика

Составьте программу, которая запрашивает число. Если введено положительное число, то на экран выводится квадрат этого числа. В противном случае выводится сообщение "Ошибка. Введено неправильное число" и повторный запрос на ввод нового числа.

Ответ:
Alferd
Alferd
09.11.2021 13:30

Программа:

Python:

while True:

   n = int(input('Введите число: '))

   if n > 0:

       print(n * n)

       break

   else:

       print('Ошибка. Введено неправильное число')

Pascal:

var

 n: integer;

begin

 while True do begin

   write('n = '); readln(n);

   if n > 0 then begin

     writeln(n * n);

     break

   end

   else writeln('Ошибка. Введено неправильное число');

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?