Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
простоНастя2228
31.01.2021 03:15 •
Информатика
На паскаль: даны три числа. удвоить те из них, которве нечетны. осталтые оставить без изменения.
Ответ:
viklya30
24.06.2020 22:56
Если просят найти среднее арифметическое, то формула (a+b+c)/3.
Если не наибольшее и не наименьшее из трёх, то
if ((a < b) and (b < c)) or ((a > b) and (b > c)) then b
else if ((b < c) and (c < a)) or ((b > c) and (c > a)) then c
else a;
Предполагается, что a <> b <> c.
0,0
(0 оценок)
Ответ:
Kember
24.06.2020 22:56
var
i: integer;
m: array [1..3] of integer;
begin
writeln('Введите три числа: ');
for i := 1 to 3 do
begin
read(m[i]);
if odd(m[i]) then write('Число нечетно: ', m[i] * 2)
else write('Число четно: ', m[i]);
writeln;
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
podenas1969
16.05.2021 20:48
Написать программу нахождения чисел кратных 3 в диапазоне от 1 до...
MoriYuka
03.07.2022 12:55
ответь произвольный :что такое сложный пароль...
настюша290204
22.01.2020 21:33
Решите информатику Задание 1,4...
Forsenboy
17.01.2022 06:29
Расскажите об отрицательных и положительных сторонах компьютерных игр...
maxwinter095
16.06.2020 05:35
На какой программе можно быстро и красиво научится рисовать....
sofiotap3
26.10.2022 11:38
Минимальным объектом, используемым в текстовом процессоре microsoft word, является: *...
Zzzasha
22.02.2023 12:39
4. На приготовление ужина у мамы ушло 2 часа. Для приготовления мясных блюд понадобилось 40% времени, десерт занял 20%, все остальное время было затрачено на приготовление...
Масим007
22.02.2023 12:39
ХХ ғ басында адамат тарихына өзіндік үлесін қосқан,әрбір үйде дүниежүзінің әр қиырынан,сан алуан ақпарат жеткізіп және көтерінкі көңіл күй сыйлаған ерекше қондырғының...
АРИНОЧКА1111111111
22.07.2022 18:55
Автомобиль едет по мосту со скоростью 15 мс. Какова кинетическая и потенциальная энергия автомобиля, если его масса — 1350 кг и высота моста — 7 м. Ускорение свободного...
adventuretime93
30.08.2022 00:11
12. Найдите бессоюзное сложное предложение. Укажите его номер. (Знаки препинания не поставлены) 1) Юрий Николаевич Либединский любил чтобы за столом была вся семья чтобы...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Если не наибольшее и не наименьшее из трёх, то
if ((a < b) and (b < c)) or ((a > b) and (b > c)) then b
else if ((b < c) and (c < a)) or ((b > c) and (c > a)) then c
else a;
Предполагается, что a <> b <> c.
i: integer;
m: array [1..3] of integer;
begin
writeln('Введите три числа: ');
for i := 1 to 3 do
begin
read(m[i]);
if odd(m[i]) then write('Число нечетно: ', m[i] * 2)
else write('Число четно: ', m[i]);
writeln;
end;
end.