В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arlashmanov
arlashmanov
23.04.2023 02:07 •  Информатика

1.Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. 2.Написать программу, которая бы по введенному номеру единицы измерения (1 — килограмм, 2 — миллиграмм, 3 — грамм, 4 — тонна, 5 — центнер) и массе М выдавала соответствующее значение массы в килограммах.
c++

Ответ:
elizaveta08071999
elizaveta08071999
24.07.2021 18:37

Простейшее задание

Объяснение:

#include <iostream>

#include <functional>

#include <string>

#include <vector>

 

struct converter

{

  std::function<double(double)> function;

  std::string to;

};

 

int main()

{

  std::vector<converter> table =

  {

     {[](double d) { return d; }, "kg"},

     {[](double d) { return d / 1000 / 1000; }, "mg"},

     {[](double d) { return d / 1000; }, "g"},

     {[](double d) { return d * 100; }, "cnt" },

     {[](double d) { return d * 1000; }, "tones" }

  };

  int ind = 0;

  std::cin >> ind;

  ind -= 1;

  if (ind >= 0 && ind < table.size())

  {

     int m = 0;

     std::cin >> m;

     const converter& current = table[ind];

     std::cout << "Result of converting " << m << " " << current.to << " is " << current.function(m) << " kg" << std::endl;

  }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?