В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dVioletta
dVioletta
19.08.2021 02:33 •  Информатика

1)составить программу которая выводит на экран каждое 5-ое число и таких чисел 20. 2)составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

Ответ:
матиматик13
матиматик13
23.06.2020 14:46
1.

var
i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(21)-10;
 for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Каждый пятый эелемент массива: ');
 for i:=1 to 20 do if i mod 5 = 0 then write(A[i]:5);
end.

2.
var
x,i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
 for i:=1 to 20 do A[i]:=random(11);for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Натуральные числа в диапазоне [5..10]: ');
 for i:=5 to 10 do write(A[i]:5);
writeln;
x:=1;
writeln('Их произведение: ');
 for i:=5 to 10 do x:=A[i]*x;
write(x:5); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?