В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AlexSubbotin11
AlexSubbotin11
07.05.2021 11:18 •  Информатика

10 . pascal abc. даны два массива. написать программу вычисляющую среднее арифметическое элементов каждого массива и сравнить эти значения.

Ответ:
annasevsehkocot
annasevsehkocot
09.10.2020 12:46

попробуй  

programm dima;

var

m1:array[1..50]of integer;

m2:array[1..50]of integer;

n1,n2,i:integer;

arifm1,arifm2:real;

 

 

begin

  writeln('Vvedite rozmeri masivov');

   readln(n1,n2);

   randomize;

   writeln('Masiv 1:');

   for i :=1 to n1 do

   begin

    m1[i]:=random(50);

    write(m1[i],' ');

    end;

    writeln;

    writeln('Masiv 2:');

   for i:=1 to n2 do

     begin

    m2[i]:=random(60);

    write(m2[i],' ');

    end;

    for i :=1 to n1 do

     arifm1:= arifm1+m1[i];

     arifm1:=arifm1/n1;

 

      for i :=1 to n2 do

     arifm2:= arifm2+m2[i];

      arifm2:=arifm2/n2;

      writeln;

      if arifm1=arifm2 then

        writeln('seredne arifmetichne rovnie')

        else

         if arifm1>arifm2 then

           writeln('seredne arifmetiche 1 masiva bilche')

            else

            writeln('seredne arifmetiche 2 masiva bilche');

  end.

   

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?