В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир

Паскаль : каждый солнечный день улитка, сидящая на дереве, поднимается вверх на 2 см., а каждый пасмурный день опускается на 1 см. в начале наблюдений улитка находится на а см. от земли на в-метровом дереве. имеется 30-элементный массив, содержащий сведения о том, был ли соответствующий день наблюдения пасмурным или солнечным. написать программу, определяющую местоположение улитки к концу 30-го дня наблюдений.

Ответ:
gamar1
gamar1
22.06.2020 11:57
Uses crt;
const n=30;
var c: array[1..n] of integer;
a,b,i:integer;
begin
randomize;
writeln('на какой высоте была улитка');
readln(a);
writeln('ведите длину ветки');
readln(b);
for i:=1 to n do
begin
c[i]:=random(2)-0;{1-солнечно;0-пасмурно}
writeln(c[i]);
end;
writeln;
for i:=1 to n do
if (c[i]=0) then a:=a-1 else a:=a+2;
writeln(a,'см');
if a>b then writeln('улитка переползла ветку');
if a=b then writeln('улитка вернулась в начальное положение');
if a=0 then writeln('улитка спустилась до земли');
end.
0,0(0 оценок)
Ответ:
JLemast
JLemast
22.06.2020 11:57
Program Ulitka;
Var SunnyDay: Array [1..30] Of Boolean;
a, b, c, i: Integer;
Begin
WriteLn('a = ');
ReadLn(a);
WriteLn('b = ');
ReadLn(b);
b := b * 100;
Randomize;
For i := 1 To 30 Do
Begin
If Random(2) = 1 Then
SunnyDay[i] := True
Else SunnyDay[i] := False;
End;
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
Begin
a := a + 2;
If a > b Then
a := b;
End
Else
Begin
a := a - 1;
If a < 0 Then
a := 0;
End;
End;
WriteLn('Дни месяца были таковы:');
For i := 1 To 30 Do Begin
If SunnyDay[i] = True Then
WriteLn(i, '. Солнечный')
Else
WriteLn(i, '. Пасмурный') End; WriteLn('К концу 30 дня местоположение улитки равно ', a, ' см над землей');
ReadLn;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?