В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
artemmishin7777777
artemmishin7777777
19.12.2021 06:41 •  Информатика

Дан двумерный целочисленный массив а(m; n)состоящий из случайных чисел от (-20; 20).найти числа в1,,равные наименьшим значением строк.написать программу в паскале

Ответ:
НикитаГоровой
НикитаГоровой
01.10.2020 11:50
Uses crt;
const n=5;
m=5;
var a:array[1..n,1..m] of integer;
i,b,j,k:integer;
begin
randomize;
for i:=1 to n do
for j:=1 to m do
begin
a[i,j]:=random(40)-20;
write(a[i,j]:3);
end;
writeln;
k:=1;
b:=20;
repeat
for i:=k to k do
for j:=1 to m do
if (a[i,j]<b) then b:=a[i,j];
writeln(b);
inc(k);
b:=20;
until k>n;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?