В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
10089675834075
10089675834075
24.05.2021 23:19 •  Информатика

Составьте программу замены местами в массиве В(16) второго и предпоследнего элемента. Ввести старый и новый массивы. И если получиться создайте блок схему)

Ответ:
voronbakhozs9gh
voronbakhozs9gh
12.06.2021 19:54

#include <iostream>

#include <cmath>

using namespace std;

int main() {

 int B[16]; // создаём пустой массив

 srand(time(NULL)); // делаем так что бы функция rand() зависла от времени и не была постоянной

 for(int i = 0; i < 16; i++) { // заполняем массив случайными числами

   B[i] = rand() % 100;

 }

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

 int tmp = B[1]; // создаём временну переменную для хранения значения 2 элемента массива

 B[1] = B[14]; // присваиваем 2 элементу значение предпоследенго

 B[14] = tmp; // присваиваем предпоследенему элементу значение временной переменной

 for(int i = 0; i < 16; i++) { // выводим массив

   cout << B[i] << ", ";

 }

 cout << endl;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?