В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
24.02.2023 04:21 •  Информатика

С ИНФОРМАТИКОЙ Задание 1
Составить программу на Паскале. Определить, сколько раз в данном тексте встречается буква «ж». Текст из 5 слов задать самостоятельно.

Задание 2
Составить программу на Паскале, которая удалит все буквы «е» из текста, который состоит из 5 слов. Текст нужно придумать самостоятельно.

Ответ:
madina20042004
madina20042004
12.06.2021 11:39

Pascal

var

 s1:string = 'Дружба от недружбы близко живёт.';

 s2:string = 'Доброе дело два века живёт.';

 i, c :integer;

begin

 c:=0;

 for i:=1 to length(s1) do

   if s1[i]='ж' then

     inc(c);

 writeln(s1, '  В предложении букв "ж"=',c);

 i:=1;

 while i <= length(s2) do

   if s2[i]='е' then

     delete(s2, i, 1)

   else

     inc(i);

 writeln(s2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?