В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Кто решит , тому 70 составить программу нахождения суммы чисел , кратных 3 в массиве м [1: 12] (числа вводятся с клавиатуры)

Ответ:
foxmanlp
foxmanlp
02.10.2020 16:08
Program enot_peredelani;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then 
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.
0,0(0 оценок)
Ответ:
long6
long6
02.10.2020 16:08
Const
  n=12;
var
  M:array[1..n] of integer;
  i,s:integer;
begin
  Writeln('Введите ',n,' элементов массива');
  s:=0;
  for i := 1 to n do
  begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
  Writeln('Сумма элементов, кратных трем, равна ',s)
end.

Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?