В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
veronikamod
veronikamod
30.01.2022 06:40 •  Информатика

Написать программу вычисления среднего арифметическое трех чисел с клавиатуры результат вывести с четырьмя знаками после запятой

Ответ:
vigura2
vigura2
01.10.2020 09:51
Pascal:
var a,b,c:real;
begin
  write ('Number 1: ');
  readln (a);
  write ('Number 2: ');
  readln (b);
  write ('Number 3: ');
  readln (c);
  writeln ('Srednee: ',(a+b+c)/3:0:4);
  readln;
end.

C++:
#include <iostream>
#include <iomanip>
using namespace std;
int main()
{
   float a,b,c;
   cout.setf(std::ios_base::fixed,std::ios_base::floatfield);
   cout <<"Number 1: ";
   cin >>a;    
   cout <<"Number 2: ";
   cin >>b;
   cout <<"Number 3: ";
   cin >>c; cout.precision(4);
   cout <<"Srednee: " <<(a+b+c)/3 <<endl;
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?