В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Tima411
Tima411
05.05.2022 05:51 •  Информатика

Напишите программу на Python для следующей задачи: "Среди четырехзначных чисел выбрать те, у которых все четыре цифры различны. "

Ответ:
osipolara
osipolara
09.03.2021 20:50

Объяснение:

n = int(input()) - #сколько чисел

for i in range(n):

   a = int(input()) #вводим числа

   if a %10 != a//10%10 and a %10 != a//100 and a //10 %10 != a//100:  #проверяем чила

       print('Yes')

   else:

       print('No')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?