В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
cksenia112
cksenia112
16.01.2023 15:44 •  Информатика

Написать программу на паскале: определить количество строк матрицы, в которых хотя бы один элемент равен t

Ответ:
voronavv2016p08wqy
voronavv2016p08wqy
17.06.2020 14:03

Program Natasha1925_2;
uses crt;
const n=50;
var
  a:array[1..n,1..n] of integer;
  t:integer;
  i,j,kwo:integer;
  yes:boolean;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  randomize;
  {создание массива}
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          a[i,j]:=random(101)-50;
          write(a[i,j]:7:2);
        end;
      writeln();
    end;
  write('Введите число t: '); read(t);
  {поиск строк}
  kwo:=0;
  for i:=1 to n do
    begin
      yes:=FALSE;
      for j:=1 to n do
        if a[i,j]=t then
          yes:=TRUE;
      if yes then kwo:=kwo+1;
    end;
 writeln('Количество строк: ',kwo);
end.

0,0(0 оценок)
Ответ:
FIREH4IR
FIREH4IR
17.06.2020 14:03

uses crt;
var
  a:array [1..100,1..100] of real;
  t:real; i,j,k:integer;
begin
  randomize;
  write('Введите количество строк матрицы: '); read(i);
  write('Введите количество столбцов матрицы: '); read(j);
  write('Введите число t: '); read(t);
  clrscr;
  for i:=1 to i do
  begin
    for j:=1 to j do
    begin
      a[i,j]:=random(100)-50;
      write(a[i,j],' ');
    end;
    writeln;
  end;
  k:=0;
  for i:= 1 to i do
  begin
    for j:= 1 to j do
    begin
      if a[i,j]=t then
      begin
        k:=k+1;
        j:=1;
        i:=i+1;
      end;
    end;
  end;
 writeln('Количество строк: ',k);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?