В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anastasiamrz
anastasiamrz
28.01.2021 18:09 •  Информатика

Напишите программу, которая определяет, является ли переданное ей натуральное число простым (простое число делится только на 1 и само на себя). ОБЯЗАТЕЛЬНО СЕЛАТЬ С РЕКУРСИЕЙ НА PYTHON!

Ответ:
EvgeshaKhomenco2005
EvgeshaKhomenco2005
22.02.2021 17:10

import sys

sys.setrecursionlimit(22000)

def func(a, i):

 if i*i<a:

   if a>=i:

     if a != i and a%i != 0:

       i+=1

       return(func(a, i))

     elif a == i:

       return ('YES')

     else:

       return('NO')

   else:

     return('NO')

 else:

   return('YES')

   

i = 2

a = int(input())

print(func(a,i))

вот, первые две строчки можете убрать, если на проверки вводятся не слишком большие числа.

буду благодарен, если отметите лучшим решением:)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?