В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lera1059
lera1059
02.07.2022 18:44 •  Информатика

Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне от -100 до 100, меняет местами первую и вторую половину массива и выводит новый массив на экран.

Ответ:
Aixerel
Aixerel
26.05.2020 17:28

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[10];

    srand(time(0));

    for(int i = 0; i < 10; i++)
    {
        a[i] = rand() % 201 - 100;

        cout << a[i] << ' ';
    }
    cout << endl;

    int temp;
    for(int i = 0; i < 5; i++)
    {
        temp = a[i];
        a[i] = a[i + 5];
        a[i + 5] = temp;
    }

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ' ';
    }
    cout << endl;

    return 0;
}


Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?