В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Рыжик151
Рыжик151
11.11.2021 11:41 •  Информатика

Напишите программу на паскале и блок схему


Напишите программу на паскале и блок схему

Ответ:
PonchikPonchikovuy
PonchikPonchikovuy
11.03.2021 21:16

program z1;

var a,m:integer;

begin

m:=30000;

repeat

read(a);

if (a <> 0) and (a mod 2 = 0) and (a mod 10 <> 2) and (m > a) then m:=a

until a = 0;

writeln(m)

end.

Объяснение:

m равно максимально возможному чётному числу (согласно условию)

Цикл с пост условием:

ввод числа

проверка числа (верно, когда верны все условия):

    не 0 (a <> 0) - не является условием окончания последовательности

    число чётное (a mod 2 = 0)

    число не оканчивается на 2 (a mod 10 <> 2)

    число меньше m (m > a)

если проверка пройдена, то переменной m присваивается значение числа

Проверка условия выхода из цикла (a = 0)

Вывод m


Напишите программу на паскале и блок схему
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?