В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tatsux2010
tatsux2010
03.06.2023 13:09 •  Информатика

Известно что а кг груш стоит x руб. Составьте программу вычисляющую цену z кг груш. Значения переменных a, x, z ввести с клавиатуры (паскаль 7 класс) даны а, b, c. Напишите программу для вычисления значения арифметичесеого выражения
x=3c²- b³ :c²+4( паскаль, 7 класс) ​

Ответ:
yesenia2007
yesenia2007
03.03.2021 22:15

Задание 1:

program prog;

var x,a,z:real;

begin

  write('Введите а кг груш и х стоимость этого количества (через пробел): '); readln(a, x);

  write('Введите z кг груш, стоимость которой надо посчитать: '); readln(z);

  write('Стоимость ', z:0:1, ' кг груш равна ', z*x/a:0:2);

end.

Задание 2:

У вас скорее всего ошибка в задании, т.к. на входе есть переменная a, а в формуле она отсутствует. Я предположил, что она на первом месте стоит.

program prog;

var a,b,c:real;

begin

  write('Введите a, b и c черезпробел: '); readln(a,b,c);

  write('3a²-b³:c²+4 = ', 3*sqr(a)-exp(3*ln(b))/sqr(c)+4:0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?